PDA

View Full Version : troubleshooting e30 cd changer


Ceeker
04-23-2009, 09:41 PM
Got a situation here:

hooked up factory radio to car; ran cd changer cable to trunk and plugged in the changer from radio to changer. had power to both units. I didn't turn on the radio yet - once I plugged the din connector into the radio the fuse blew, and the radio fuse under the hood went as well.

Does anyone know what could possibly be wrong?

El Gato Liso
04-23-2009, 09:45 PM
bad ground

the stock brown wire is the ground wire

Ceeker
04-23-2009, 09:49 PM
ground wire to changer or the deck? the deck works fine until I plug the din plug into the deck.

WillieE30
04-24-2009, 06:36 PM
You have a dead short to ground. Check your pin outs on the din plug. Did you try the changer before plugging into the radio? and, is the changer designed to go with that radio?....Sometimes the people that design this stuff place a diode across the positive power in the ciruit to ground(negative) as protection for cross polarity in connection. If this diode shorts it can cause your problem or if the polarity is wrong....Good-luck

Ceeker
04-24-2009, 08:08 PM
ok, I'll check that; someone else told me to make sure the din pins are ok. Yes the changer works. I powered it up before plugging it in to the deck. As I understand the deck does go with the changer. The din configuration is unique - as usual with bmw shit. They keep changing stuff. I get a feeling it's in the changer and not the deck. I just hope its not in the cable itself.

thanks for the info, appreciate it. :-)