PDA

View Full Version : Trouble Starting 318 is


Tekals
04-05-2009, 01:11 AM
Hi, I've been having some trouble starting my bimmer lately, it began by a simple no response when turning the key to start, like if i wasnt doing my "anti-theft security". It wasnt that bad at first, I just shorted the starter to make it turn a bit, go back inside the car and it would usually work.

At the moment, it got really worst, now when i try to start, it does way more than just not starting, It does a small noise and I lose everything electrical, meaning it shuts down everything and even if I turn switch on/off, i dont get back any lights in my dash.... To get it back i think i could unplug battery... but still it does the same each time...

At first i thought it was my starter, I took it out and tried it on a battery... worked fine... had little rust on them, i fixed this before putting it back hoping it could be a bad contact. WRONG, still does the same &?%/ again...

Do you guys have any suggestion? My bro thinks it could be a bad key switch, what you guys think?

SamE30e
04-05-2009, 01:26 AM
Bad ground?

Tekals
04-13-2009, 10:06 PM
Where are the grounds on the engine? I've seen one on the rightside near exhaust, but it looks fine... any other grounds i should check?

Tekals
04-13-2009, 10:15 PM
Took the starter out again, tried it again and again, looks to be alright but sometimes the contact looks hard to get to make it run. Although, i took out the starter switch with all the connections, couldn't find an electric scheme about it but we tested it in all positions and it looked to work fine. The "starting" position gives voltage on one of the wires but it seems that the signal doesnt reach the starter... where could it be dying?, it is a mess of wires under the dash!
Any scheme of the wire from the key switch to the starter? where it goes and all?
Any Idea of where the anti-theft thing could be?

andicanada
04-13-2009, 11:42 PM
change the ignition switch in the rear behinde the lock cylinder the conact goes sometimes bad and give's you the reported problem

kungfucious
04-17-2009, 02:40 AM
hey guys... little unrelated...
did the 318is come with a power sunroof? i think all i's came with the turn knob and is' came with the power one. is that correct?

Tekals
04-17-2009, 08:27 AM
i beleive it was an option, mine doesnt have power sunroof

noid
04-17-2009, 04:08 PM
Take a a set of jumper cables and connect one end of the ground to the oil drain plug and clamp the other ground end to the steering rack (dont worry about the power cable). Then try to start it... then report back.