PDA

View Full Version : Damn It


Dado 540
03-17-2009, 08:33 PM
Damn DSC light is constantly on

Damn ABS light comes on for 20 sec when i turn the car on and goes off.

Damn it!

*uzi* DSC ABS :mad:

dodoamore
03-18-2009, 10:46 PM
I feel your pain., keep us posted on the issue., gl

Dado 540
03-18-2009, 11:05 PM
Well i prayed and prayed, and now hte lights went away. Im keeping my fingers crossed and hope they stay off!

Bimmerjoe thanks for the reply! I dont really know where to go from here.

Dado 540
03-19-2009, 12:31 PM
Agh lol but the lights are back on. It hought maybe the sensor was dirty, but now its gotta be busted.

MLue1
03-19-2009, 12:32 PM
...I dont really know where to go from here.Get the codes scanned maybe it logged a code that will pin point the cause.

Dado 540
03-19-2009, 01:12 PM
Mark you been MIA for a while. What poppin

damameke
03-19-2009, 07:05 PM
Agh lol but the lights are back on. It hought maybe the sensor was dirty, but now its gotta be busted.

give it a few days, it might go away, I had the same issue as you
last summer and I called BMW SA and thats what he told me ,
and it went away..its $120 for BMW just to analyse it.

else it might be faulty sensors

MLue1
03-19-2009, 08:28 PM
Mark you been MIA for a while. What poppinThe wife been sick and still getting over surgery. I just popped in for a bit and saw your post.

It has been said that E39 can throw codes and symptoms that sometimes mysteriously disappear, so lets hope that this is one of them.

EDIT: BTW the speed sensors are the same hall effect sensors that BMW like to use, they contain a magnet that gets weak over time and because of this the sensor(s) are hard to troubleshoot with a multimeter so the BMW mechanics wind up swapping them out to find which one is causing the problem.

cdb
03-19-2009, 08:53 PM
My ABS/DSC lights light up whenever I hit a pothole or large bump with my front left wheel I've noticed. Sometimes they come one for a couple seconds after a damp day / night as well. You never knoww.....

Dado 540
03-19-2009, 10:39 PM
The wife been sick and still getting over surgery. I just popped in for a bit and saw your post.

It has been said that E39 can throw codes and symptoms that sometimes mysteriously disappear, so lets hope that this is one of them.

EDIT: BTW the speed sensors are the same hall effect sensors that BMW like to use, they contain a magnet that gets weak over time and because of this the sensor(s) are hard to troubleshoot with a multimeter so the BMW mechanics wind up swapping them out to find which one is causing the problem.


Hope all is well now.

myndgone
03-19-2009, 11:59 PM
Mine was staying on because of corroded sensor wire...

Dado 540
03-20-2009, 05:39 PM
Did you have her scanned to determeine which wheel?

dodoamore
03-20-2009, 09:10 PM
Its my understanding that a gt1 can locate the busted sensor., we should have a group scan/abs party I'm sure there are numerous members with an orange lit dash that may be interested...lol.,

cdb
03-20-2009, 11:02 PM
Its my understanding that a gt1 can locate the busted sensor., we should have a group scan/abs party I'm sure there are numerous members with an orange lit dash that may be interested...lol.,

Haha I'm all in. And a DRL delete while were at it.

Dado 540
03-21-2009, 07:09 PM
Ok that sounds like a deal.

Im in. So far 3 guys. Anyone else???

jasonlau8023
03-21-2009, 08:34 PM
i'm in , is this group activity will solve my problem?
http://www.maxbimmer.com/forums/showthread.php?t=117755

so, when and where are you guys want to go?

dodoamore
03-21-2009, 10:20 PM
*th-up* Seems like there is a bit of an interest in scheduling a scan-2-gether; I will contact Roco at RMP to see if we can work out a group price (let say 5 of us). If anyone else would like to check-in with another GT1 shop I welcome another option (non stealerships pls). I will post a follow-up mid-week with price and time availability.

Dado 540
03-22-2009, 12:06 AM
dodoamore thanks alot. When you do find out, could you also shoot me a PM.

Thanks

dodoamore
03-22-2009, 11:32 AM
Absolutely.,

archrival
03-22-2009, 01:51 PM
I've got it too! doing a traction control delete soon but still dont want to see the ABS light. anyone know how much this might cost?

Paul540/m3
03-22-2009, 02:02 PM
I have the same issue( front sensors are coroded), Maranello wants $240 a side for the front speed sensors. Got some new aftermarket ones off ebay for $45USD a side. Will see how they work and report back.

RMPMOTORS
03-22-2009, 05:53 PM
Many times you can remove the senser and clean the mounting serface and senser and re-install it, and no more light!!

Cheaper then buying a new part.

Give me a call and I can scan your car to pin point which senser is causing the problem!!

*th-up*

dodoamore
03-22-2009, 09:57 PM
Keep us posted Paul.,

Roco I'll call you this week, hopefully we can schedule a group stop-in....

Marco.,

dodoamore
03-25-2009, 10:29 PM
Dado540, jasonlau8023, cdb, paul540.....pm's sent....*th-up*

porksoda
03-25-2009, 10:38 PM
Many times you can remove the senser and clean the mounting serface and senser and re-install it, and no more light!!

Cheaper then buying a new part.

Give me a call and I can scan your car to pin point which senser is causing the problem!!

*th-up*

you guys changed location?!?! got a gt1 as well or another scanner?

europrince
03-26-2009, 09:57 PM
:mad:gotta love those e39 gremlins

BoostedMX
03-26-2009, 10:32 PM
I would love to be part of that group for the deal if there was one, but i'm in Windsor.

Dado 540
03-27-2009, 03:26 AM
My lights have been off this whole week. The car has a mind of its own.

MLue1
03-27-2009, 09:13 AM
:mad:gotta love those e39 gremlins+1 As a precausion to poor connection(s) as my car ages I have resorted to coating the connections with a bit of dielectric grease whenever I disconnect a connector. This is something that the guys with the vintage cars do to keep the grounds and other connections from corroding.

Paul540/m3
03-29-2009, 11:22 PM
I have the same issue( front sensors are coroded), Maranello wants $240 a side for the front speed sensors. Got some new aftermarket ones off ebay for $45USD a side. Will see how they work and report back.

Sensors arrived and were installed. So far so good. Total parts bill was $165 CDN including shipping/exchange.

Trouble65
03-30-2009, 10:40 AM
My won't go off everytime I press down with the right foot LOL.

Having said that my son has a problem with his 325is lights for break sensor and abs come on and off. Going to wait until they stay on before attempting to fix.

MLue1
03-30-2009, 12:44 PM
Did anyone think to check the brake fluid level? You never know!

Dado 540
03-30-2009, 02:08 PM
Good point, but its a pain in the but removing that filter housing.

overlordjd
03-30-2009, 07:05 PM
Mine kept comming on and off so I got the car scanned and found out it was my right front speed sensor. 15 min replace job and it never came back on. hopefully it is nothing more serious than that on yours.

5thseries
03-30-2009, 07:30 PM
Kick your car.

dodoamore
03-30-2009, 09:42 PM
Well here's where I'm at.,
1st - ABS module was rebuilt to fix trans safe code; fixed main issue, but didn't fix 3 orange light; whatever who needs abs during the winter lol.,

2nd - 4mths later scanned the e39, because I had a CEL and carsoft indicated valve relay code., my current guess is the rebuilt module is &^%$ since I continue to keep blowing the abs fuse.,

Next Step - before purchasing any sensors, is to find a working used one or better yet if anyone has a functioning module and willing to lend a hand and let me test it :*)., Anyways let me know and I'll keep you gents posted.,

Dado 540
03-30-2009, 11:53 PM
How is the ABS module connected to the Trans Failsafe Program?

I had that pop up and had the tranny done.

Jave
03-31-2009, 08:20 AM
Just an FYI for anyone taking the sensors out and attempting to clean them, they are very likely to break as you take them out so be very careful. I have the lights on and managed to break both front sensors as I took them out to clean them (plastic mount piece just fell apart) so now I have to get two sensors either way *thmbsdwn*