PDA

View Full Version : Is it REBUILT or NEW - MAF from autopartsway.ca


Dado 540
03-11-2009, 04:01 PM
I ordred a MAF sensor form Autopartsway.ca yesterday. Well the order came in this morning. I open the box and i see this beat up Bosch box and the sensor itself has different screws than the original safety torx. I called and asked if this is a rebuilt part, they say no.

Please see the pics and tell me what you think. I even wiped around the screws and it was dirty. I debating if i should send it back or just use it anyways. Part was $300.

Damn pics are huge, sorry.

Quack
03-11-2009, 04:10 PM
that looks used, the box has been retaped, and the electrical connector looks old & corroded, you got the shaft, I've replaced over a hundred MAF's and all the Bosch boxes are in mint shape with minimal tape, and the MAF sensor itself was very clean.

Gamite
03-11-2009, 04:10 PM
definately doesn't look new.

Dado 540
03-11-2009, 04:23 PM
Damn it, that what i said too. Im calling them right now!

BSL
03-11-2009, 05:28 PM
Looks like you just got jammed :(
I hope they honour a return.

Maybe email them a link to this thread

Dado 540
03-11-2009, 05:34 PM
I called and filed for a return. Now i gotta wait up to 72 hours to get some return number. And ofcourse im gonna have to pay for shipping.

The address on the box that it came in was 4915 Bathurst St #209 M2R 1X9 North York.
Hopefully i can bring it there.

Im even thinking of going there to see wtf and whytf they sent me this shit.

arsevader
03-11-2009, 05:38 PM
Definitely old. I bet some unscrupulous person sent their old MAF back as a return and it wasn't checked properly.

Dado 540
03-11-2009, 05:41 PM
Looking at the housing there are no sratches on the tabs where the clips go.

So im thinking its rebuilt. And look at those screws, OEM screws are safety torx

craigIS
03-11-2009, 06:28 PM
i would tell them your not going to pay for the return shipping. its their mistake. someone on their end didnt preform their job properly, you paid for a new one, and thats not what you got. you shouldnt have to pay for the companies mistake, they should take ful responsibility if they truly value thei customers.

TNation
03-11-2009, 06:32 PM
that's definitely not new! look at how worn the electrical connector is!

Dado 540
03-11-2009, 06:36 PM
They have their damn Return Policy that states that the customer has to pay for returns.
But i will most definitely tell them to cover all the cost, since i paid for a new part.
Will also throw in that i will post on every forum about their parts that i got.
As mentioned will attach the link to this page so they see whats good.

Miguel
03-12-2009, 12:23 AM
If you paid with Visa, threaten to file a claim... you'll get your money back.

craigIS
03-12-2009, 11:36 AM
They have their damn Return Policy that states that the customer has to pay for returns.
But i will most definitely tell them to cover all the cost, since i paid for a new part.
Will also throw in that i will post on every forum about their parts that i got.
As mentioned will attach the link to this page so they see whats good.

I have been in customer service for years, and have never heard of a customer having to pay for something to be returned. you paid for something new, and thats what you should get. its not like you paid new part price to have a used part sent, so you can spend more money to return the used part at cost to you! if you used visa, you can tell them your putting in a claim, and if that doesnt work, then put in a claim. if they want to be assholes im sure you can be one right back. all thats fair is fair.