PDA

View Full Version : No power to my 1998 e39 528i


BiturboSI
11-16-2008, 04:35 PM
Hi folks, I went on a 2.5 week vacation, came back and there was no power to the car what so ever.
I thought it was the battery, I changed it and still nothing. Is there a switch or a fuse that could be the cause? Is it a security thing that the car disables itself after sitting for over two weeks?

Right before I left, there was no issues what so ever!

Any advise most appreciated.

propr'one
11-16-2008, 04:51 PM
there's no power to the car at all?

BiturboSI
11-16-2008, 05:22 PM
absolutely nothing, though we messed around with the fuze box in the glove compartment, all the fuzes seem to be ok, however when I moved it around a bit, I got power to the car for a few seconds then nothing.

Trouble65
11-16-2008, 06:49 PM
Loose connection or corrosion however where?

Dado 540
11-16-2008, 06:57 PM
when you get it going Seafoam that baby! LOL

Pinto009
11-16-2008, 08:49 PM
you sure its not the contacts is the second batt your useing good try to jump start it see if it starts if it dose then it either you batt or your connector jump start whit the contact on the front of your car or you can even hook up your jump star cable form you second batt to the front of you car and see if that works gl ... Dado lmao

Bhead
11-16-2008, 09:43 PM
when you get it going Seafoam that baby! LOL

Seafoam real does the job base on it's high risk formula. It can erode your seals without any problem.

BiturboSI
11-16-2008, 11:18 PM
I am going to try tomorrow morning as well, if nothing works, I may have to tow it to Charlie or the nearset BMW dealer. Caching $$$$..... :(

BiturboSI
11-19-2008, 04:31 PM
Folks, an update...it turns out that the wire coming from the battery to the fuse box was corroded due to salt under the carpet that most like accumilated over the years on the passanger side, this caused the wires to short and drain the batteries as well as blow a few fuses.

it's now nice and clean and problem fixed.

So lessons learnt for me is to ensure I clean under the carpets as well at least once a year.

Thanks everyone for your advice.

Dado 540
11-20-2008, 12:37 AM
What was the damage on the diagnosis from the dealership $$$

BiturboSI
11-20-2008, 12:40 AM
Only 5 hours of labor and $10 for parts hehe

so around $680 including tax, not bad!

Dado 540
11-20-2008, 12:48 AM
****ing labour!

dodoamore
11-20-2008, 01:27 PM
Ooch....You would think they would have the heart to move on the labour...since the part cost only 10 bucks.....geezus....

God bless independent shops, or enthusiast who lend a helping hand....

europrince
11-20-2008, 01:32 PM
Wow, not cheap. Well, its back on the road, so that's good. I had a 97 540, so I know all about spending money on stupid stuff for that car.