PDA

View Full Version : out of the blue: 98 528i mechanical problems


cdb
09-15-2008, 05:44 PM
Arite guys. So I drove home with ease Monday night and parked the car. Woke up this morning, started her up and drove here closer up to the garage to give her a wash. The car started and ran just fine for these few seconds of movement. After the wash, I go to start her up and park at the end of the driveway, with no such luck. The car started, then immediately the revs died down and the engine stopped. Tried a few more times with no success. I have a feeling it is a problem with fuel getting to the engine. The car turns over just fine and does start, but then immediately dies. Maybe a fuel pump?
Any suggestions from you guys?

Christian

VSanj
09-15-2008, 08:29 PM
once you get the car started step on the gas get your RPM's up to around 2-3000 hold it there for 10 seconds.....car will stay started once you let go of gas.

Mine did the exact same thing after a through wash once, never did it again

cdb
09-16-2008, 10:14 AM
Tried that. No luck.

MLue1
09-16-2008, 11:25 AM
Arite guys. So I drove home with ease Monday night and parked the car. Woke up this morning, started her up and drove here closer up to the garage to give her a wash. The car started and ran just fine for these few seconds of movement. After the wash, I go to start her up and park at the end of the driveway, with no such luck. The car started, then immediately the revs died down and the engine stopped. Tried a few more times with no success. I have a feeling it is a problem with fuel getting to the engine. The car turns over just fine and does start, but then immediately dies. Maybe a fuel pump?
Any suggestions from you guys?

Christianjust throwing these out... the MAF/connections located at the front of the car or the DME/connections which is located under the right side cabin filter, its sealed but you never know...when you wash the car a lot of water runs down the windshield into this area.