PDA

View Full Version : 325e sounds like a diesel


BRAD 82
07-14-2008, 06:22 PM
Hello,

I am looking for some advice/help for my car.

when the car starts and runs (not really) it sounds like a diesel engine. Not to mention there is absolutely NO power to move the car with.

I believe that this is due to water in the gas.

any help/tips would be greatly appreciated.

Thanks,
Brad

slimjim
07-14-2008, 09:14 PM
i dont know but this may be due to shitty injectors......because when injectors are old the can make that "tic tic tic tic tic" noise

BRAD 82
07-14-2008, 10:25 PM
and i guess water going through them probably finished them off?

Thanks slimjim!

Anyone else have any ideas

mirek
07-14-2008, 10:34 PM
Run a compression test

BRAD 82
07-14-2008, 10:47 PM
how do i do that?

slimjim
07-14-2008, 11:16 PM
if u are getting water in ur engine, when the car starts or struggles to, white smoke would come out of ur exhaust. u might even have cracked rings? its hard to say.

is there anything else u notice when u start or try starting the car, did anything prior to this problem happen like overheating?

BRAD 82
07-14-2008, 11:23 PM
no it isn't water IN the engine constantly. it game from gas purchased.

it was water in the gas that caused the issue. tank has been drained now.

mirek
07-15-2008, 12:02 AM
get a compression tester, and google for instructions, or take it to charlie, shouldn't take longer than half an hr.

InfiniteDice
07-15-2008, 02:25 AM
if it sounds like a loud lawnmower, or helicopter then its the bottom end bearings.

Had that sound on my old engine, tore it apart before putting in my new engine, all the crank bearings were scored.

Every engine gets some white smoke, and water for the first 5 to 10 mins. beyond that, does your coolant level get low? could be leaking coolant internally.

Later man.

SamE30e
07-15-2008, 07:36 AM
My car does it too. It seems to be a normal ETA thing these days. It's the timing reference sensor, or the engine speed sensor one of the two on the bellhousing of the tranny.

Bullet Ride
07-15-2008, 07:39 AM
could be leaking coolant internally.

Yeah, I had a vehicle that had that problem once, it only started sounding like a diesel engine though when the damage was bad enough (due to the lack of lubrication because of the dilution of the oil) that i needed an engine rebuild (new block)

BRAD 82
07-15-2008, 08:11 AM
engine ran fine before the issue of watered down gasoline.

will be getting a compression tester today and doing one tomorrow.

I hope its not too major of a problem. but i guess the compression test will tell me that! I am thinking it is a head gasket

slimjim
07-15-2008, 07:59 PM
how do u know it was watered down gasoline?

BRAD 82
07-15-2008, 08:39 PM
Well I never personnally saw it but the guy I bought the car off of said that was what happened. He also said it was drained.

That's what I have to go on. I am planning on running a compression test tomorrow to see what I get. Personnally I think it may be the cylinder head gasget. But we will see.

BRAD 82
07-17-2008, 06:38 PM
Ok. Ran the compression test and got 120psi on cylinders 1,2,3,5 and got 100psi on cylinders 4 & 6.

All the spark plugs are worn and probably need changing but this still doesn't mean the engine would sound like a diesel. Would it?

HELP PLEASE!!!

noid
07-17-2008, 07:17 PM
Im not quite sure what the minimal compression for an b27 is but i know for the b25 mine is around 180. However thats besides the point. Whats important is the variance between the cylinders and that all cylinders have compression. It seems by your numbers that the engine should still be able to run smoothly (not like a diesel).

If i were you i would use lucas injector cleaner or seafoam to see if that will clean up the insides.

slimjim
07-17-2008, 08:18 PM
can u film it and post a vid?

BRAD 82
07-17-2008, 09:16 PM
You want me to film the car when it starts and while running?

LeftRights
07-17-2008, 09:33 PM
TUNE UP! 1st trust me

5thseries
07-17-2008, 10:01 PM
Check out your plugs or your distributer, and your wires
The plugs may be used all up
Look at your distributer for any kind of build up
If the car successfully turns over but idles like crap, then its the plugs possibly.. check those out.

noid
07-18-2008, 12:02 AM
Its not the wires. I put on my spare wires while brandon still had it and it was still the same.

mirek
07-18-2008, 02:57 AM
That's some pretty low compression, 100? eek. should be ~180 through all 6

e24_635csi
07-18-2008, 07:51 AM
maybe the cat is plugged, i picked up at 528e, and sounded the same way. had absolutly no guts, and sounded awful. once we cut the cat off, it ran fine. just a thought.

BRAD 82
07-18-2008, 09:26 AM
ok will start with the tune and go from there! if that doesn't work then i will cut the cat off and see what happens then!

Thanks guys will keep you posted!

BRAD 82
07-18-2008, 09:28 AM
That's some pretty low compression, 100? eek. should be ~180 through all 6

Granted that i have never done a compression test before and the kit i got wasn't a perfect fit in the sprakplug hole but it would appear that i got pretty close to the same result right the way accross.

I was more so looking for consistency. but i think once i do a tune up and clean her up a bit that should help.

Thanks,

Brad

BRAD 82
07-19-2008, 09:53 AM
Does anyone know where a tune up kit would be sold at a good price?

I went to lakeside motors yesterday and mike said that if you are going to do a tune you have to do a valve adjustment.

Is this true? 280$ a good price?

noid
07-19-2008, 12:11 PM
you dont have to do a valve adjustment unless you want to. No part of the tune up requires you to take off the valve cover.

mirek
07-19-2008, 03:42 PM
280$ for a valve adjustment? you can do that yourself.

Axxe
07-19-2008, 07:28 PM
Valve adjustment on M20s only affects valve noise, not how shitty the car runs. Unless there is a much larger problem, he's basically try to **** you over. For $280 you can get a complete mint running eta engine.

mirek
07-19-2008, 11:35 PM
And don't go cutting your cat off just because you suspect it's clogged.

Why not just take it to the bimmersport, they should be able to diagnose it pretty quick, b

BRAD 82
07-20-2008, 11:04 AM
I believe that bimmersport is quite away from where I live?

280$ was for the parts and labour for a tune up with valve adjustment.

I think that I will try the spark plugs first and see what happens.

BRAD 82
08-01-2008, 09:27 AM
Just had a thought...

on the cluster of this car it says that the car is chipped... now i have heard that if the chip starts to malfunction this could cause a lot of issues?

Any ideas...

anyone wanting to lend a hand saturday?

calegrant
08-04-2008, 07:09 PM
280$ was for the parts and labour for a tune up with valve adjustment.

That's a rip-off for a valve adjustment considering it shouldn't take more than 1.5 hours and the only part that MAY be required is a valve cover gasket. If you have to replace rocker guides or something maybe...but thats damn steep. Like anyone has said previously, take it to one of the sponsor shops. Save you money and aggravation.