PDA

View Full Version : Spark Plugs


slimjim
07-12-2008, 02:12 PM
so yesterday my car started to act all funky and its idling was rough and the engine was choppy when i was giving gas. I suspected a vacum leak and found out my intake boot was ripped. I got another one from bmw, but still the problem existed. today i checked the spark plugs and found that cylinder #1 wasnt working!!! so i took out the plug and found out that it bridged.

i researched bridging and found out it was a common problom on e30 which use platinum plugs, can anyone verify? And what plugs do you guys use?

e30_kid89
07-12-2008, 02:19 PM
Use the OE Bosch copper plugs. M20's hate hat platium +4 crap.

slimjim
07-12-2008, 02:34 PM
Use the OE Bosch copper plugs. M20's hate hat platium +4 crap.

ya, i ordered some like 40min ago :)

noid
07-13-2008, 03:51 PM
theres a good 2 threads about how much the platniums suck on bf.c

InfiniteDice
07-13-2008, 09:11 PM
oe is bosch silver... for 12$ a plug i'll pass.

I've been using ngk, work great.

If that plug is bridging, I'll tell you now, you have an issue. Oil is getting past somewhere. I ran bosch plats for years, and while it's true that they bridge easier than a regular plug, they are not the source problem.

slimjim
07-16-2008, 09:43 PM
^^^^i looked up on a couple of forums, they all say something like " Plat sucks fking shit in M20's and will bridge"...problem solved.

and how long have u had the platinum plugs in? i had mine almost 2 years before the one bridged.