PDA

View Full Version : Z3 factory alarm problem


Tooms22
06-02-2008, 01:06 PM
Hi - 1997 BMW Z3 1.9l

I just had a new cd deck installed. I'm guessing the installer had to disconnect the battery. Prior to the install the factory alarm and power locks worked 100%. Now when I try and arm the system,(factory 2 button FOB) I get 3 chirps and it won't lock. I press the unlock button and get the same 3 chirps. Do I need to reset my alarm or something?

I'm sure some of you guys have run into the same problem... what do I need to do to have it reset, OR how do I fix this? Thanks

coolhand
06-02-2008, 02:21 PM
Take it back and tell them they ****ed it up.

Tooms22
06-02-2008, 06:49 PM
Does anyone know of how to "reset" it or something?

Oakvillez3
06-02-2008, 10:09 PM
your factory head unit that came with your z3 has a post like thing that is attached to the back of the unit. this post goes through a sensor behind the unit which in turn engages the alarm system. your new head unit would not have the post, so the alarm will not work and you will get 3 chirps. the quickest way to fix, is it remove your new head unit and disconnect the sensor behind the unit. once you get in there you will see the sensor which is a square plastic thing. good luck

Tooms22
06-04-2008, 06:14 PM
THE "3 CHIRPS BUT CAN'T LOCK/ARM THE CAR WITH REMOTE"....

Problem solved! - I hope this short write up can be of use to others.

The factory installed plug 'n play alarms on E36/7's have a wired piece (separate from factory head unit's wiring harness) It's a plastic square that has a small square opening (big enough to fit your baby finger in.) This opening has 2 little pins sticking down on one end, and a lever-or-sort coming from the other.

A tech at the dealership told me that when the "lever and pins touch, it sends a signal to the alarm saying the stereo has been removed, but when the pins and lever are separated, it thinks the deck is in. In short, I put a rubber plug in the opening to separate the lever and pins and VOILA!!!, the remote locks and arms the car again.