PDA

View Full Version : Fuel Pump ...


kemestry
01-28-2008, 08:03 PM
Wondering if I can get some help.
I'm in need of a fuel pump for an 89 325i.

Car started chugging on Sheppard, made it to my underground parking and then just quit. I lifted the seat, turned the ignition and listened for the pump and didn't hear the buzz. Checked fuses and what not so I'm assuming that its the pump. If there are any other suggestions, feel free.

Mike

supernaught
01-29-2008, 09:37 AM
car will turn over but no chug to life. Pumps are not always noisy, my white IX has a dead silent pump. feels like you're out of gas.
You might be out of gas.

T.Dot_E30
01-29-2008, 09:59 AM
Don't assume it is the pump without having someone test it properly.

You need to ensure the pump is getting power, if it is not getting power, you need to trace things back, first to the main relay.

El Gato Liso
01-29-2008, 10:27 AM
Fuse 11

Dropped325i
01-29-2008, 12:02 PM
i believe the bently gives you current specs of what the pump should draw, and thats how i tested mine when i was having issues with my car, just use an amp meter and break the positive circuit and run inline.. i can relook up the specs when i get home and post them.

just unplug it, and apply external 12v directly to it, and run a current meter between.

slimjim
01-29-2008, 11:10 PM
car will turn over but no chug to life. Pumps are not always noisy, my white IX has a dead silent pump. feels like you're out of gas.
You might be out of gas.

*th-up* lol this happened to me.

its a stupid mistake but it happens, my gauge wasnt showing it was empty, but it was empty.