PDA

View Full Version : Ignition help needed


SamE30e
01-20-2008, 06:45 PM
I need help bad.

I was at my friends house in guelph. About 75km away from my house. I had just washed my car earlier that day and it was running perfectly. I went inside my friends house for about an hour or two and came out and my car wouldn't start. It cranks over, but doesn't start, I cranked over for a good 5 minutes until I smelt fuel. I left it over night and came back in the morning and tried again, again, no dice.

I'm assuming its getting fuel because I can smell it.

There is no spark though, I pulled the wire off the coil and checked to see if it would arc on a ground (in this case the intake manifold) and again no dice.

From what I understand the coil is on a constant 12v and the ground is triggered by something. The coil is getting 12v, if I put a test light to the - side of the coil and the + of the battery and crank it over the light doesn't go. It has a brand new MSD Blaster SS II coil I put in 2 days ago with no problem and worked fine up until now.

I'm assuming that whatever triggers the coil is not working properly, all the fuses are fine and none are blown.

I'm waiting for the tow truck to come get it and bring it back to my house, I need my car urgently and if you guys could help out that'd be awesome..

If I put a test light to the positive of the battery, and the negative of the coil, should the light flicker when I crank it over?


Thanks

Sam

Max_VQ
01-20-2008, 08:13 PM
I would try two things:
(1) Try to start the car again, with the throttle wide open. In the cold weather it can take quite a while for a flooded engine to clear.

(2) Put on the coil you just took off.

I don't know if you will see the test light flash, the frequency might be too high. (depending on how many pulses per crankshaft rev)

e30_kid89
01-20-2008, 08:27 PM
Put the stock coil back on and see if it works.

SamE30e
01-20-2008, 10:48 PM
I'll try the coil tomorrow, its -20 out lol. If that doesn't work i'll cry.

FuryriderX
01-20-2008, 11:09 PM
+1 to trying the stock coil again. You are right about the coil being +12 constant. The ground is triggered by motronic. The pulses are in the millisecond range, so its highly unlikely you'd see anything on a test light.

i dont know what else to say - maybe take out the motronic box and see if water got into it? that can cause all kinds of crazy hard-to-diagnose problems.

El Gato Liso
01-21-2008, 01:16 AM
TRUST me

FUSE #11, 7.5A put a new one in. then your problem will be solved !

El Gato Liso
01-21-2008, 01:26 AM
...nvm you already checked the fuses...

SamE30e
01-21-2008, 10:52 AM
Changed the coil back and nothing...

SamE30e
01-21-2008, 10:59 AM
The fuel pump is working, I can hear it when I turn the key.

e30_kid89
01-21-2008, 11:53 AM
do you have one of those spark tester thingys? Check it and see if its getting a sparkshizzle.

SamE30e
01-21-2008, 05:14 PM
It's not getting spark, I checked by pulling a plug out and grounding it.

e30_kid89
01-21-2008, 05:34 PM
Check the dist. cap and rotor - Maybe it crapped out there.

Aveman
01-21-2008, 05:52 PM
Check the dist. cap and rotor - Maybe it crapped out there.


Yeah, pull off the wire that goes to the distributor from the coil and try grounding that to see if there is spark. If there is, then you know it's distributor/rotor related. Chances are that is where your problem lies, if you do not see spark right off the coil then your ecu is not driving it, and you said you can hear the fuel pump so that would mean your ecu is getting power and is able to trigger the fuel pump but maybe not able to drive the coil (fried coil driver on the ecu). Not sure what year your eta is but I have a motronic 1.0 eta ecu from my 85 that you can have if you find your ecu is fried.

Ej_Red
01-21-2008, 09:54 PM
I had similar problems. Still have them. Although i saw a yellowish spark though. I have a feeling it's the coil itself.

What i did is i took sparkplugs out and dried them with a heat gun and pressed the gas pedal all the way down and cranked it. It worked few times for me. I still haven't figured the problem out.

SamE30e
01-22-2008, 11:05 PM
Fixed...

Timing reference sensor was fux0reddd

FuryriderX
01-22-2008, 11:51 PM
reeally. you mean the VR sensor on the crank wheel? did you source a new one? how much did that run you?

SamE30e
01-23-2008, 03:30 PM
No it was the timing reference sensor on the tranny. The bottom one, the top one is the engine speed sensor.

The one on the harmonic balancer is the TDC sensor.

Ej_Red
01-24-2008, 08:44 PM
Where exactly is that sensor located? And how did you get to diagnose it? Did you have any spark from the coil?

SamE30e
01-25-2008, 12:44 AM
The sensor is located on the lower left side of the bell housing of the transmission. The engine speed sensor is the one of the top and the timing reference sensor is the one on the bottom.

I diagnosed it by starting from the engine and working my way back, plug were good, wires, coil, coil wires, ecu. Then I remembered that when I changed my clutch I saw a ****ed up sensor. I check out what the sensor did and put two and two together and got a new one. Plugged it in and it fired right up.

And no there was no spark when the sensor was broken.